Back to overview
Resolved
margin.cafe is having issues
Aug 13, 2026 at 8:59pm UTC
Affected services
margin.cafe PDS
Resolved
Aug 13, 2026 at 10:08pm UTC
We’re back! margin.cafe should be up and running. Thanks for bearing with us.
Affected services
Updated
Aug 13, 2026 at 9:15pm UTC
We've deployed a fix and are seeing recovery for margin.cafe. We're continuing to monitor the situation closely before marking this as fully resolved. We'll post another update shortly.
Affected services
Created
Aug 13, 2026 at 8:59pm UTC
We’re investigating an issue with margin.cafe that is impacting some users. We’re working to fix the problem as quickly as we can. We’ll share another update shortly.
Affected services