Back to overview
Resolved

Helsinki region having issues

Jul 2, 2026 at 9:06am UTC
Affected services
AT Protocol PDS (margin.cafe)

Resolved
Jul 2, 2026 at 9:22am UTC

Seems to be resolved

Created
Jul 2, 2026 at 9:06am UTC

Hetzner HEL-1 is currently having some issues, margin.cafe is affected by this.