Back to overview
Resolved

Our database is dying

Jul 28, 2026 at 11:20am UTC
Affected services
Margin
Marque
margin.cafe PDS
Stratus
Cirrus

Resolved
Jul 28, 2026 at 11:40am UTC

We fixed it

Created
Jul 28, 2026 at 11:20am UTC

We are working on it